WordPressを別のサーバーへ移転した際に、

Warning: continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in...

というエラーが、WEBページ側とWPの管理画面側の両方に表示された。表示された箇所はヘッダー付近。

ちょっと焦ったが、管理画面のダッシュボードにWordPress本体の更新を促すメッセージがあったため、すぐに更新。
すると、エラー文は出なくなった。

調べたら下記のことに気づいた方がみえました。

PHP7.3からbreakの代わりにcontinueを使うとWarningになる。

参考サイト PHP7.3からbreakの代わりにcontinueを使うとWarningになる。

continue、break付近の問題のようですね。
WordPress本体を更新することで解消されたようです。
なにはともあれ解決できて一安心。面倒な修正作業が増えなくてよかった。